Создание DLL обёрток нужной версии .NET на основе файлов TLB

Автор Тема: Создание DLL обёрток нужной версии .NET на основе файлов TLB  (Прочитано 2175 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Андрей БушманАвтор темы

  • ADN Club
  • *****
  • Сообщений: 2000
  • Карма: 163
  • Пишу программки...
    • Блог
  • Skype: Compositum78
Проблема (правда окольным путём решаемая) с генерацией DLL обёрток нужной версии .NET подробно  изложена мною здесь. К сожалению, на работе я не могу проверить это при подключении ссылок в C# проекте MS VS 2008 и 2005, т.к. при установке этих версий IDE я ставил только компоненты для разработки C++ и VB.NET (не думал, что мне в них может понадобиться C#). Попытка доустановить недостающие компоненты (из под учётки админа) заканчивается ничем (скрин прилагается ниже). Полагаю, что это баг, появление которого может быть обусловлено наличием установленного на IDE обновления (SP), а так же наличием установленных более новых версий IDE.

Однако, попытки подключить указанные ранее TLB файлы в MS VS 2005\2008 даже в гоблинских проектах VB.NET (за неимением кухарки имеем дворника (с)) выдают всё ту же ошибку, которая была мною обозначена в блоге, так что скорее всего и с проектом C# будет та же петрушка.

Поэтому вопросов, собственно, два:
1. У кого-то получается средствами VS 2005\2008 успешно подключить к C# проекту обозначенные мною TLB файлы из ObjectARX SDK 2010?

2. Может всё же как-то можно утилите tlbimp.exe указать целевую версию .NET, не прибегая к использованию tlbimp.exe из разных Windows SDK?
« Последнее редактирование: 18-03-2014, 13:04:23 от Андрей Бушман »